Warning file DLACTRLW.EXE is infected

Each time I open any programs on my computer this error pop-ups.

“Warning, application cannot be executed. The file DLACTRLW.EXE is infected. Please activate your antivirus software.”

Then it will prompt a new window with the software. I don’t want to install the software but it continues whatever I clicked. Please help.


  1. waseem

    here is ur solution.
    DLACTRLW.exe is a
    Sonic’s Drive Letter Access (DLA) Component. Sonic’s Drive Letter Access is software which enables you to drag and drop files from Windows Explorer straight onto the drive letter corresponding to your CD/DVD-Writer, or to save files directly onto CD/DVD from within Windows programs, such as from within your Wordprocessor, from within your spreadsheet programs, etc… This is called packet writing software. Packet writing software usually has the major drawback that the only guarantee you have is that you will be able to read the CDs/DVDs in the same drive that you created them in – there is no guarantee you will be able to read them in another PC. Sonic’s Drive Letter Access is different thanks to its Make Compatible feature which creates CDs and DVDs in Universal Data Format (UDF) so that you can rest assured that you will be able to use the CDs and DVDs you created with Sonic DLA, in other PCs. Sonic’s DLA can be bought as a product on its own, or it also gets installed as part of the Sonic’s RecordNow! CD/DVD-Writing software (which often comes as part of the software bundle on many laptops). This task, DLACTRLW, implements the Sonic Drive Letter Access support on your PC.

    Here is its solution:

    Down to end-user preference. If you find that you have this task because it came bundled with your laptop but you prefer using a different CD/DVD-Recording program which has its own packet writing interface, then either disable this task on the Startups tab or uninstall Sonic RecordNow! and/or Sonic Drive Letter Access through the “Add\Remove Programs” icon in the Control Panel.

  2. jt

    This is a trojan/spyware problem not a problem with the burning software

  3. Adam

    Yes, this is a very nasty virus . It probably goes hand in hand with system security pop up telling you how many viruses you have and how to easily solve the problem by buying this new software. It is under the guise of a windows operating system but it really couldn’t be further from the truth. My computer is currently infected and I will be trying tonight ot sort it out. I’ll let you know how it goes. You should be able to do something in safe mode to sort it out but not system restore as part of the virus sets your system restore point to just after you contracted the virus. Very sneaky feature that is.

  4. mary

    Adam, how did it go?
    I have just encountered this problem

  5. Kelly Wright

    Looks like a sign of System Security infection. Nasty pest because it blocks execution of EXE files and prevents antivirus software from running. So it’s kinda difficult to download and install any cleaner. I’m currently working with one victim to help her get rid of this malware. Will see how it goes.

  6. greg

    hey….just two hours ago my pc started behaving just as you all described. the virus even dodged my mc afee anti virus app.

    has anybody gotten rid of this beast…..and how?

    can’t even try and load a antivirus cd or load the app on a usb stick…. the virus has stopped me dead in my tracks

  7. Mark

    Before you get all excited about reading this because you think that I was able to fix this – let your hopes be dashed. Read on if you want to see what I have tried.

    One of the users in my organization just got infected with this. You are right when you say this is a nasty virus, or rather trojan. Neither Symantec, AVG nor Spybot were able to prevent the infection. Here’s what I had to deal with. Not all of the problems are necessarily results of this one trojan, but likely they are.

    Basically, upon logging in, there is a blue background screen yelling at you in red and white letters “WARNING! YOUR”RE IN DANGER!” (please note the poor English, that’s not my typo ;o) ) and other nice things. It then runs a fake scan and wants you to purchase a program to help you save your PC (heard it all before, right?). The program disallows the user to run any executables, so once you log onto your PC you cannot run any removal software, the task manager or other helpful tools. The program even seemed to block starting Windows XP in safe mode.

    I ended up being able to boot into safe mode using the laptops’ system diagnostic (hopefully you can run the regular safe mode). That allowed me to open the startup using the “msconfig” command from the run menu. In the startup, I disabled ever item that I did not recognize (or could not cross reference). Meanwhile I ran a Symantec scan and came on a Trojan (sorry, did not write down the name) which I let Symantec quarantine. I rebooted the system, but the effect SEEMED the same: Same background, fake scan running in the foreground, etc, but this time I could run executables. In the Process tab of the task manager, process DLACTRLW.EXE was running but couldn’t be terminated. Running Symantec again found (related or not) “Bloodhound.Exploit.213” and “Trojan.Bredolab” before shutting me out of the application (?). I ran Spybot and came up with 5 more kinds of Trojans, Malware and changed security settings (one of which prohibited System Restores). I was able to remove all but one kind of problem, requiring a restart/scan. Did that.

    And the PC started right back at square 1. My next step: Reformat. Has anybody come up with a better solution?

  8. Beyond Birthday


  9. Me

    ihaupd32.exe keeps shuting down my pc after 1 minuet exactly.

  10. marty tyler

    you have a security virus here is how to cure
    go to start
    type in c/
    that will open some folders
    select all users
    look for application data and open it
    if you dont c it type application data at the end of address bar
    this to should open a bunch of folders
    you should now see a folder that is named with a bunch of numbers
    and when you open it the files inside will be numbered the same
    i want you to right click each of them and rename them badfile
    then back out and rename folder badfile
    restart your computer and after it comes back up run your anti virus program i run stop sign and malware bytes antimalware this shoul catch it and remove it for you.
    if you have any further probs just e-mail me and i will try to help thanks

  11. Bruce Hemmer

    I had the same thing happen to two of my computers at the house. It originated from downloading music files and videos on Limewire. I was able to get rid of it by when I first turn on the computer, hitting “control, alt, delete to get up the windows task manager. I found something with a bunch of numbers starting and I disabled it. Then I went into my computer, C Drive, Documents and Settings, All Users, Aplication Data(This is a hidden folder, make sure you mark on your folder options to see hidden folders). This is where you will find a file with a bunch of numbers. I can’t tell you what numbers are because in both of the computers that it happened to here, one of them started with the number 7 anouther one started with the number 1 . It should match the numbers that you stopped from the windows task manager. Once you find the file, delete it, then delete it from your recycle bin. I haven’t had any more problems with that virus since I did that, but I did delete and forbid the kids from using Limewire.

  12. ryan

    thanks bruce!

  13. Glenda

    Hi Bruce
    Quick question… Does the file also include some letters? I’m looking at a few folders with letters and numbers and I see them under the c drive. Are these the folders you’re indicating?

  14. Matt

    Darn. I have this same problem. The folder is named “91df8003a06dfea5c80c” and is just sitting there on my C/ drive.
    When I try to delete it, I get an error message:
    “Cannot delete filterpipelineprinterproc.dll: access is denied. Make sure the disk is not full or write-protected and that the file is not currently in use.”

    In Windows Task Manager, I cannot “end process” for a program called “DLACRLW.EXE” when I click end process, nothing happens.

    I searched for DLACRLW.EXE and it looks like it is not the program that is discussed at the top of this thread because it is not in the correct place.

    HELP! PLEASE! How do I kill this thing?
    Is this the computer swine flu?

  15. Julie

    I cant find the application data I found Userdata is this the samething? Also the files that are in there have letters and numbers like C5MHN29 and if i open them there blank inside nothing stored in them?

  16. Josh

    The process on my computer was named flfjsysguard.exe

  17. Danny

    HEY EVERYONE!! Here is A simple way to solve this!

    I know what your going through!! its happend to me before too!

    this is malware and it will prevent you from opening programs that might get rid of it (or just plain any program lol)

    but there is hope!

    download this: hxxp://download.bleepingcomputer.com/grinler/rkill.com

    run it, it will disable the malware so you can open up malwarebytes


    do a full scan!!

    Delete everything it finds and reboot your computer, this should solve your problem!


  18. Jorge Orofino

    No. pop up a banner application cannot be executed

  19. Ethan

    I just got the virus too a few hours ago. It currently appears that, after reading what you guys wrote, I have beaten it. Who knows, but here’s how I did it:

    When I start up my computer I have two usernames: mine, and my father’s, who set up my computer and created his own username. The virus had thoroughly infected my username to the point that, like everyone has mentioned, I couldn’t open files, I couldn’t do system restore, it had changed my desktop background to that vicious message about how my wife and children would find out my every keystroke. That scared the s— out of me.

    I logged into my dad’s username, and the virus had not infected it. I logged onto the internet and downloaded the latest Norton AntiVirus. I ran a full scan, but it only found a few cookies, which I deleted. I rebooted, signed into my username, and the virus was still there.

    So I went back into my dad’s username and downloaded Malwarebytes, like you guys suggested, which was CRUCIAL. I ran a full computer scan, which identified 5 Trojans, or Malware, or whatever the hell they’re called. I fixed all of them, and checked that they were quarantined and deleted.

    I rebooted and logged into my username. It seemed everything was fine. I looked in my Start menu, and “System Tool 2011,” the clearly fake anti-virus program that kept showing up that was clearly a function of the real virus, was still on my start menu. I went into Windows Explorer and went to Options to view all of the hidden files I could. I basically searched extensively throughout my Windows Explorer to find System Tool 2011 in any form I could. I found one, and looked at its properties. It had a certain long, funky file name of many letters and numbers. I went to All Users, Available Data, and found that file name, and deleted the s*** out of it.

    I searched throughout my Windows Explorer trying to rid it of any suspicious files. Right now, looks like I’m A-okay.

    Hope this helps anyone, past or future.

  20. John B

    Ethan’s solution worked for me too.

  21. Chris

    Brucs’s solution worked for me too. You have to be quick. If Windows coming up press crtl-alt-del, select the special process (mine started with b1…) and hit delete and enter. then delete it from harddrive. thank you!

  22. Martinh

    here’s how I got rid of it, used Bruce’s method from the point of get up the windows task manager. I found something with a bunch of numbers starting and I disabled it. Then I went into my computer, C Drive, Documents and Settings, All Users, Application Data(This is a hidden folder, make sure you mark on your folder options to see hidden folders).

    I then hovered over the field that looked full of numbers and letters and it told me it had been created the day I had the problem (so I knew it was the file in question) i then just put it in the Recycle Bin and then emptied the R Bin, ran a virus scan and restarted computer and it was gone, thanks all for your help.

  23. Nicky

    I have copied Bruce’s method too & can see a filw with last nights date in it – obviously the naughty file in question, but it will NOT let me delete it – It says
    “Cannot delete jkmAnCe06300.exe Access is denied.
    Make sure the Disk is not full or write-protected & that the file is currently not is use”

    It’s driving me insane

    Please help anyway you can

  24. Nicky

    I did it again & so far all good….. it’s gone. Hurrah!

  25. arjun

    please tell me how to delete this file named BGSA……. from my nokia x2

  26. NiceBlackLady

    I did a system restore while in safemode and everything seems to be fine now.
    The methods suggested above did not work for me.??. I couldn’t open task manager to delete those weird numbers. And the virus wouldn’t let me run the mailware anti-virus software.
    So far so good.

  27. Savedme

    My father got this virus on his Dell inspiron 6400 laptop. He had no active protection. I used a empty usb memory stick to drag and drop Microsoft Security Essentials (MSE for the rest of this post) onto the laptop. I rebooted, clicked On MSE and began installing. I did this the very second I could see the program, not waiting at all for a complete boot up. It’s a race against the clock with this one. After several attempts to beat the final boot up program(the Virus), and losing the race. I added one more thing. Knowing I was most likely going to have to erase and reinstall Windows, I did a CTRL ALT DELETE, the second I got the MSE installing. I began shutting down Processes that I did not recognize as necessary. I’m no super computer geek, but I figured if I screw it up, i’m back to Windows reinstall worst case. We’ll I guess I shut down the right process. I was able to fully install MSE. It would not run until an update could take place. I ran an internet wire (Cat 5 cable) from my router, updated MSE and ran it. BAM!!, screw you virus. I got it all. Did a full scan last night, nothing showing as of the next day(right now). I know this is a bit vague, but the info here prior was not helping me, so I tried something else. If you would like some help re:closing processes, to get some control back. Shoot me a comment on my blog smartphonenoob.com and I’ll try to help out.

  28. Trisha

    I was unable to open task-manager so I did what was suggested above…my computer-c drive-documents&settings-all users-application data-find weirdly named file(a bunch of letters and numbers)-delete content and folder-clear recycle bin. BUT, it would not let me delete everything b/c it said it was ‘in use’ blah blah blah so when rebooting it’s a race against the clock to do the above deleting *before* the virus-prog has a chance to open. It worked purrfectly for me. It’s an extremely irritating virus.

  29. oc

    had same problem. could not use any programs. did safe reboot and system restore to yesterday’s date. everything seems fine. running malwarebytes shows nothing is infected. seems like easiest solution.

  30. Luke

    Thx Bruce, your method of how to delete the nasty virus helped me at work. I was infecvted on one of the computers with this malware and did it the way how bruce suggested. It work. Now I'[m scanning the computer with the mallware program and hopfully all the viruses will be removed;)

    Thx again

  31. Irene

    Start in Safe Mode. Choose “System Restore”. Pick a date you are certain predates infection. You should be good to go.

  32. OddRadiance

    Safe Mode & System Restore seems to have done the trick. I’m cautiously optimistic. This nasty virus had me shaking in my cute lil shoes because it wouldn’t even let me open Task Manager! Thank you to ALL the posts/posters…..I just kept trying stuff until something worked!

Comments are closed.