Speedbit Search on my homepage

I am using Google Chome and Speedbit Search is now set as my default homepage. I never configure it to be that way. How does it happen? I tried to set Google as my default homepage but it is already stuck with Speedbit Search. Each time I run the browser it is automatically start with http://home.speedbit.com/.

Please help me, I need to restore my previous homepage settings. As of now, removing Speedbit Search seems to be impossible. Every change I made to my browser can be easily wiped out by Speedbit. Is there a way to permanently remove this garbage search from my browser? I need quick advice.

Thanks
Drew Gorvin

3 Responses

  1. Dwayne says:

    There is no way that you can remove Speedbit Search if the main program is still present. First you must go to control panel, add/remove programs and uninstall DAP, Search Predict, Speedbit, or Download Accelerator. If you cannot find any of these, perhaps it has a new title. Just find any suspicious program.

    After the uninstall process, remove the remove the extensions, here are the steps:
    – Open Google Chrome and click the wrench icon. It is located on upper-right of your browser
    – Click Tools > Extensions
    – Remove Speedbit or any related extensions
    – On left sidebar, just below the ‘Extensions’, click on Settings
    – Find and click the ‘Manage search engines…’ button
    – Set your default search settings to Google, Bing, Yahoo, or anything except Speedbit because you cannot deactivate it while it is set as your default search engine.

    Please post what happened.
    Dwayne

  2. Brian says:

    To remove Speedbit.com, click on Start. Then click on Control panel. Now click on Programmes and features. Highlight and then go to uninstall.
    Now click on Google Chrome and then click on the three bars in the top right hand corner of the screen. This will open a panel…go down to settings. Click on Settings. This will open the chrome settings page. Go to Search and click on Manage search engines. This will open where the search engines are located. Bring your curser down to Speedbit.com and move to the end of the highlight. Across will appear. Click on the cross and the search engine will be deleted. Now go to Google.com and make it your default search engine. Your default browser should say Google or Google Chrome or Bing or whatever you choose.
    I trust this will help. Brian

  3. Jim says:

    I am having the same problem as Dwayne. After installing the speedbit video accelerator I went to Chrome to try it out. Upon opening the browser I saw 2 pages of small typed reasons as to why the accelerator was incomparable. I immediately closed the browser and uninstalled the program. However I still cannot get rid of the speedbit search engine. I have deleted it several times, went inot the regedit and deleted it and it continues to come back. Please help.