Welcome to NGINX virus blocks my Internet browsing

Hi there, this is my first post on this forum. Every time I try to use the Internet or browse Yahoo, Google, Facebook, and Youtube, I always get a welcome screen saying “Welcome to NGINX.” Then the browser hangs in there. I cannot proceed with the browsing. This happens on almost every browser I am using including Internet Explorer, Firefox, and Chrome. Also, there are times that it will show 404 error or Page Not Found.

I am worried that it has become a network problem in our office because the same thing happens when accessing the Internet using a Macbook Pro. How did this NGINX virus able to enter our computers if we have a good security in place? How can I remove the “Welcome to NGINX” screen on our web browsers? I need help.

Comments 23

  • If you are using a web/proxy server in your office, try to flush cache pages and see if Welcome to NGINX is gone. In addition, you can try to delete browsing history for your entire browser. Here is the procedure.

    Internet Explorer:
    1. Open Internet Explorer.
    2. Go to Tools menu. Select “Internet Options”.
    3. On Browsing History area, click on “Delete” button.
    4. Press “Delete” to confirm the action.
    5. Restart Internet Explorer.

    Mozzila Firefox:
    1. Open Mozilla Firefox Internet browser.
    2. Go to Tools > Options.
    3. Select “Advanced” tab.
    4. Find the area that says “Cached Web Content.” Click the “Clear Now” button.
    5. Find the area that says “Offline Web Content and User Data.” Click the “Clear Now” button.
    6. That should remove cached copy of Welcome to NGINX page.
    7. Restart Firefox.

    Google Chrome:
    1. Open Google Chrome.
    2. Click on the Wrench icon located at upper right corner. Select “Settings” from the list.
    3. Select “Under the Hood” on the left portion and click on “Clear browsing data…” on the right.
    4. You may select the period if you wish or select “the beginning of time” to clear all cache data.
    5. Confirm by pressing “Clear browsing data” button.
    6. Please restart Google Chrome.

    This procedure will only flush/remove the Welcome to NGINX page on your computer. If a virus or adware caused it, you should scan the PC with anti-virus program.

  • The problem is that most of the “antivirus” programs–even the professional ones–aren’t catching this problem. It’s a real pain in the butt. It’s bigger than clearing the cache, it involves safe mode with networking and is annoying as hell.

  • So if Crapple fans are so confident on their macs not gitteng any virus, why do you even use the anti-virus software? Not so confident now are we? Yeah, PCs Windows get the bast majority of viruses, but if you know how to really use a computer, you will never get any.

  • First Of All: Its Not A Virus At All. Nginx! (pronounced Engine-x) is a little russian browser software (like google or yahoo) and recently it has released all kinds of tracking cookies to sites lke google, yahoo,ect(why i am not sure its just what all the pages are saying on google).Cookies That were supposed to redrect you to Their page (so They get your hits: So You use Their Software) but it wasnt very long before they were found out & said pages with cookies removed.If You Get A Blank Screen That Says “Welcome To Nginx!” Its No Virus. Its A Browser Redirect (To No Page) but instead of saying Cannot Display Webpage, it just says nginx. After Some Research(well alot of research) i was finally able to figure ths crap out. I Dont Think Its A Virus(at least i dont have one) HOWEVER i still have not been able to get rid of the crap. I Had to find nother route to google.ca that worked; then made that my homepage. That was my awnser. ind a homepage and try to open different sections(search/images/video/music/WHATEVER) it was just the Main pages that i had problems with
    And Note: I DONT KNOW ANY OF THIS FOR SURE OR NOT Imstill trying to figure it out myself.i know how u feel.

  • I just followed MikeyP steps regarding NGINX on Mozilla Firefox. Now everything go back to normal. Its so easy to follow and its true. Thanks bro!

  • MickeyP, I love you! I read about a lot of other ‘solutions’ before seeing yours. It is definitely the least complicated and it worked like a charm… incredibly easy! I have IE .

  • Welcome to NGINX! is the same type of message you get when you install a web server like Apache2 for the first time (with Apache it says: “it Works!”). NGINX is a highly-efficient web server, typically used in datacenters and/or high traffic sites.

    My take on the issue is that Google is adding front-end web servers and have added them to the load-balancers before they were fully configured to redirect google’s main page. So each time you try to hit Google’s home page you will randomly get either the home page or you will hit an unconfigured NGINX server. You might hit the unconfigured servers often as they are likely to have the less load (I suppose their load balancers might be redistributing load based on each server’s load instead of round-robin scheme).

  • The advise given above worked for me!!. I will re-copy it from the person who writes on this web. All credit given to him:
    Mozzila Firefox:
    1. Open Mozilla Firefox Internet browser.
    2. Go to Tools > Options.
    3. Select “Advanced” tab.
    4. Find the area that says “Cached Web Content.” Click the “Clear Now” button.
    5. Find the area that says “Offline Web Content and User Data.” Click the “Clear Now” button.
    6. That should remove cached copy of Welcome to NGINX page.
    7. Restart Firefox.

  • thank’s mikeyP for the advised, it really works. ”,)

  • Simple, elegant, and it works. Thank you.

  • just right click the browser and open as administrator and it shud work…….

  • It’s amazing how many absurdly crap solutions there are to this when it’s just as simple as clearing one’s browsing history..

  • Thanks mikeyP it worked for me!!! Whew!

  • Listen, folks, nginx per se is a legitimate software powering over 70,000,000 websites on the Internet. Some of these websites are made malicious by their owners. We try to maintain the page below (check the link) to help people overcome “Welcome to nginx!” effects. However if you’re affected by a malware pointing you to a malicious server, check everything VERY thoroughly. It can be your OS settings (typically DNS), your browser, actual malware on your PC, your home router settings changed.
    http://nginx.org/en/docs/welcome_nginx_facebook.html

  • Hey there,

    I faced the same problem too twice, and manage to get rid of it.
    Here’s how i done it, hope it helps, i know it’s terribly annoying!
    I’m not sure how it got into the PC, but from what i observe, these things started to happen after i use Viper Scan.
    However i am able to get rid of Nginx for the first time using Norton Power Eraser, this was an advice i read from an article online.

    For the second time, i happen to delete & clear all the cache, cookies from my browser, then i used Norton Power Eraser again for assurance, eventhough the scan didn’t really show any problem this time.

    Hope it helps : )

  • NGINX is a huge problem . The way to fix it is to check the Master Boot Record on the C drive. Use MBRchk.exe to see if the MBR is authentic or fake. I fake you need to repair it. I paid Mcaffee $90 to fix the problem,

  • Nginx issue, didn’t happen on all webpage’s though as some would load fine and be normal BUT some URL’s would come up with white page with NginX at the top. no proxy’s found in Firefox or IE to redirect webpages, 2x AV software finds nothing / 2x malware software found nothing, followed MikeyP’s fix and worked instantly, been monitoring for a few days now and the problem hasn’t come back and all webpages are now accessible. Thank You MikeyP!!!!

    Here’s the fix that worked for me!!! – copied from MikeyP’s post above: (I cleared both IE and Firefox)

    Internet Explorer:
    1. Open Internet Explorer.
    2. Go to Tools menu. Select “Internet Options”.
    3. On Browsing History area, click on “Delete” button.
    4. Press “Delete” to confirm the action.
    5. Restart Internet Explorer.

    Mozzila Firefox:
    1. Open Mozilla Firefox Internet browser.
    2. Go to Tools > Options.
    3. Select “Advanced” tab.
    4. Find the area that says “Cached Web Content.” Click the “Clear Now” button.
    5. Find the area that says “Offline Web Content and User Data.” Click the “Clear Now” button.
    6. That should remove cached copy of Welcome to NGINX page.
    7. Restart Firefox.

  • Thank you, Magic Mike. I am NOT tech savvy and once I followed your directions, this worked, after 2 days of messing w/ this.

    Whatever it all means, you’re super helpful – thank you!

  • I have a slight variation of this Nginx virus.
    When I go to google, it says page can’t be found and in the center if the screen in small text it says nginx.
    To top it off, my hosts file is hidden and read only . Using attrib -s -h -r tells me access denied.
    Using filemon (procmon) I can see a svchost process going crazy doing tons of stuff, so I stop that PID process but it starts up again
    boot time.
    It’s and very old box and used as a secondary unit but still would like to find a solution, just to know.

  • Hello,
    I had the same issue on my IE and at first, following mikeyP steps did not work, but after, I set my homepage to some other site and then back to google, and that seemed to clear whatever was cached.
    thansk MikeP.

  • You people must understand that “Welcome to nginx!” is not a virus or malware. It is a server response code when you attempt to visit a problematic web site. In some cases, this will appear if you have a malware on the system that changes certain network configuration. Here’s what you should do to stop seeing “Welcome to nginx!”

    1. Verify that your Network settings, especially TCP/IP and DNS settings. Make sure that they are using your network defaults address.

    2. Flush your DNS resolver cache by using a program called Minitoolbox. You can also execute this manually by opening a CMD windows and type this command, ‘ipconfig /flushdns’. Hit Enter on your keyboard to start the process. This will only take few seconds to complete.

    3. Clean your Windows Hosts file for needles items. Default hosts file should end with one entry, that is ‘127.0.0.1 localhost’. Access your hosts file by opening Windows Explorer and browse to the folder C:\WINDOWS\System32\drivers\etc\. Use Notepad to access this file.

    4. Remove risky plug-ins from your Internet browser. Refer to Internet Explorer, Mozilla Firefox, and Google Chrome’s “Help” are regarding the procedures of uninstalling plug-ins and extension.

    5. Lastly, try to reload the web page if you are seeing “Welcome to nginx!” If it remains on that status, try deleting or clearing browser cache. Again, please refer to your browser’s support guide in performing these tasks.

  • Can anyone please help me how to remove that for Mac? Mine is Safari 4. Thanks!!!!!

  • Hi nginxs welcome page keeps popping up on my mains screen every 5 mins i tried clearing browser history ntn working plz help it says debian and nginx i blocked all ads but still popping up

Leave a Reply

Your email address will not be published. Required fields are marked *