Remove “Related Searches” Sidebar

Just recently, my computer begins to show weird “Related Searches” “T”sidebar. It will just pop-up whenever I am doing online search. Normal online browsing does not show this sidebar. I may not worry about this “T” sidebar if I find it useful. However, with the irrelevant search result, I can confirm that “Related Searches” is worthless.

This thing started to appear when I download a video player. Aside from this sidebar, there is also a toolbar on my Internet Explorer. There is no worry about it, I have taken care and got rid of it with single scan of AdwCleaner. Only problem left unsolved is this “Related Searches” sidebar. I can say that this is the most annoying adware I have ever encountered. It occupies almost half of my screen. There is no way to close or disable this adware.

Looking at my add-on, I can’t see any items relevant to “Related Searches” sidebar. I also check all installed programs but found nothing that can lead me to remove the adware. Please tell me how to remove this thing off my browser.

Thanks,
Luckysoldier

Comments 40

  • The “Related Searches” sidebar with white T logo you are seeing on the browser is part of an adware called WebCake. Previously, another adware called Conduit is issuing the same thing. Follow the procedures below to remove that annoying sidebar.

    Uninstall “Related Searches” Sidebar from Microsoft Windows
    1. Open Windows Control Panel.
    2. Choose Programs (Uninstall a Program).
    3. It will open a list of installed programs, find Webcake, Conduit, or any suspicious term and click on ‘Uninstall’.

    How to remove “Related Searches” Sidebar on Internet Explorer
    1. Open Internet Explorer.
    2. On top menu, go to Tools > Manage Add-ons.
    3. On right panel look for Webcake, Conduit, or any suspicious entry and click on Disable button to stop the service.
    4. You may now restart Internet Explorer.

    How to Uninstall “Related Searches” Sidebar in Google Chrome
    1. Open Google Chrome Internet browser.
    2. Click on Settings (three horizontal bars icon or wrench icon for old versions) or ‘Customize and Control Google Chrome’ button located on top right corner of the browser.
    3. Click on Tools > Extensions from the drop-down list.
    4. You can see Webcake or Conduit from the list of installed extensions; remove it by clicking on the ‘Trash’ icon.
    5. Please restart Google Chrome.

    How to Remove “Related Searches” Sidebar in Mozilla Firefox
    1. Open Mozilla Firefox Internet browser.
    2. On top menu, go to Tools > Add-ons.
    3. Remove Browser Webcake or Conduit from the list of installed add-ons.
    4. Restart Mozilla Firefox.

  • Hi, tried this method to no avail, there is no “webcake or conduit” to disable, any other way of finding out where they are? thanks kind regards.

  • I had the same issue I removed it by disabling Webcake extensions in my addons.

  • I had the same issue and removed it by disabling the Yontoo Extension.

  • Thanks.. It works!!!!!

  • Thanks.. It works!!!

  • Thanks , it helped.

  • removed it by disabling the Yontoo Extension

  • Unfortunately the solution above no longer works, I removed the Delta Toolbar under tools- add ins, nothing else is listed there, but that aggravating Related Search sidebar, along with an ad at the bottom of the screen, relentlessly keeps popping up. Nothing in add remove programs, maleware bytes finds nothing with the 8-25 update, of course Symantic Antivirus finds nothing (it never does). Any other ideas would be much appreciated and thanks in advance!

  • Got it! The sidebar virus is now called “Browse Firefox”. I thought that was, of course, legitimate… I disabled it and no more “Related Searches” pop up sidebar or ads at the bottom! Very cleaver but not cleaver enough! Ha!

  • thank you very much!
    I’m from VietNam, I’ve just searched many web site by Vietnamese but don’t have any website can do it! I just setup and success! Your forum very good, thanks

  • Thank u very much! It works… ;)

  • Thanks a lot for this. It really works.
    I removed something called the leap motion and got rid of that annoying side bar.

  • Removing yontoo worked. How did this get on my computer?

  • Even if you click on T it will take you to the url topictorch.com/supportWebConnect.aspx#. There are two box ENABLE and DISABLE. Click on disable and remover web connect from window and IE. How to remove is explained on the site.

  • Just fixed this issue but I got the idea here. The extension I removed is Leap Frog hope this helps! Thanks for providing tips

  • I had to remove “linkswift” and my related search and unwanted pop-up ads went away. Thanks for the information.

  • it worked, but i removed a program call quicklink

  • I tried your suggestions, but there were no listings for “Webcake” or “Conduit” under “Manage Add-ons”. I used “REGEDIT” to remove any mention of “Webcake” or “Conduit”. Then, I used “Programs and Features” on the control panel to look up “Webcake” and “Conduit”. No Listings. However, I did see several programs I didn’t recognize. I removed those programs, and now there’s no more “Related Searches” panel. FYI.

  • I removed LinkSwift from AddRemove programs and there is no “T related searches” on left side in IE8.

  • Wow! Thanks very much, It worked perfectly.

  • If you are using Firefox, remove every damn “toolbar” from the add ons

  • I have removed a program called “luck leap”. It works

  • The only extension I have on google chrome is Speed Dial and I can’t get rid of this stupid related searches crap!!! Someone please help I’m really considering taking a hammer to this piece of crap

  • I’d been having trouble with this for a while, until I uninstalled a program called “SerialTrunc” from the control program. If you click the blue T on the sidebar, it takes you to the website (which is completely safe; no viruses), and tells you how to uninstall/disable this program from different OS’s.

  • It didn’t only throw up the side bar, it did strange things with my scrolling and the search bar. I found a thing called “RightSurf” which I uninstalled. Magic! All gone.

  • Thanks.. It works!!!

  • My problem has been with Google Chrome. Been getting that darn related search sidebar. I went to the control panel and uninstalled a program called “Bat Browse” and problem gone. Looks like these programs are being disguised by different names. Good luck.

  • Even if you click on T it will take you to the url topictorch.com/supportWebConnect.aspx#. There are two box ENABLE and DISABLE. Click on disable and remover web connect from window and IE. How to remove is explained on the site.

    This resolved the issue for me…Thanks a lot Vipul for the comment

  • Mine was stubborn, but I clicked on the ‘T’ and found options to remove it and/or deactivate it. Check yours. It told me go to Windows>Control Panel>Add/Remove Programs>Remove Bizzybolt. And it worked!

  • Yeah, mine was stubborn, too. Once I uninstalled a few curious looking programs from my computer (I wish I noted which ones, but I think the culprit may have been one that said it was some sort of browser), the problem was solved. Thanks for the help!

  • I got rid of the “related topics” by disabling FindRight: Tools -> Add-ons -> Extensions. This kind of junk is why browsers will go out of business. If I want something, I’ll add it. Don’t put it up for me with no way for me to obviously get rid of it. I’d change to another browser (from Mozilla) if I had a choice of one that didn’t do this sort of stuff. I’m looking and then bye, bye, Mozilla.

  • Remove “Jotzey” extension from Add-Ons.

  • Hi guys,

    Now is “lookinglink” and I’ve uninstall it from Control Panel.

    Cheers.

  • Removed “Mega Browse” from the control panel and add-ons.

  • I disabled an extension called Surfstatic 1.0.1 and all the pop ups are gone from the firefox…. at least till now.

  • another name it could be hiding under is WebSpades. They all can be deleted from the control panel. You might have a bar at the bottom saying how trustworthy the website is, with an ad next to it. Near the ad should be “about this ad” (or something along those lines) and if you click on that, it SHOULD tell you what yours is called.

  • Hi,
    I’ve had this monstrous hindrance for ages! It was literary a waste of space!! I simply couldn’t fathom which program was the culprit. Then it dawned on me. I clicked on the T at the top left-hand corner of the Related Searches and it showed the installation source. This was Pacfunction and I did see it in the program list but I was a bit wary to just remove it. Now I felt confident that I could simply uninstall this without hesitation. YES IT WORKED!!!!!!!! I hope this was helpful.
    Cheers.
    M.

  • sir,
    please give me solution to remove “related searches”. When i am opening any site my full page is opened but after that some part will be covered by related search

Leave a Reply

Your email address will not be published. Required fields are marked *